Difference between revisions of "Bering-uClibc 6.2.x - Changelog"

From bering-uClibc
Jump to: navigation, search
(Changes between 6.2.0-beta1 and 6.2.0-alpha2)
(Changes between 6.2.2-rc2 and 6.2.2-rc1)
 
(177 intermediate revisions by the same user not shown)
Line 7: Line 7:
 
|}
 
|}
 
----
 
----
==Changes between 6.2.0-beta1 and 6.2.0-alpha2==
+
==Changes between 6.2.2-rc2 and 6.2.2-rc1==
 
(unreleased)
 
(unreleased)
  
;kernel: updated to upstream version 4.14.92
+
;kernel:
 +
:updated to upstream version 4.14.138
 +
:geode-architecture: build the hardware random generator into the kernel and remove unnecessary modules
 +
;dhcpcd: updated to version 7.2.3 with important security fixes
 +
;libbsd: updated to upstream version 0.10.0
 +
;libell: updated to upstream version 0.21
 +
;libndp: updated to upstream version 1.7
 +
;mpg123: updated to upstream version 1.25.11
 +
;clamav: updated to upstream version 0.101.3
 +
 
 +
;New Package:
 +
;libarchive: Multi-format archive and compression library
 +
 
 +
==Changes between 6.2.2-rc1 and 6.2.1==
 +
(released 7 Aug 2019)
 +
 
 +
;general: provide images with signed packages only
 +
:fix WRAP image to support the max avail baud rate of 57600 instead of too fast chosen speed of 115200
 +
;kernel: updated to upstream version 4.14.135
 +
: (re)add bcm2835 watchdog module for Raspberry Pi 3
 +
:increase kmemleak initial buffer size
 +
;axel: updated to upstream version 2.17.5
 +
;bash: updated to upstream version 5.0 - patch level 007
 +
;busybox: updated to upstream version 1.31.0
 +
;curl: updated to upstream version 7.65.3
 +
;dbus: updated to upstream version 1.12.16
 +
;e2fsprogs: updated to upstream version 1.45.2
 +
;ethtool: updated to upstream version 5.2
 +
;expat: updated to upstream version 2.2.7
 +
;ipset: updated to upstream version 7.3
 +
;ixgbe: updated to 5.6.1
 +
;keepalived: updated to upstream version 2.0.17
 +
;libevent: updated to upstream version 2.1.11
 +
;libssh2: updated to upstream version 1.9.0
 +
;lighttpd: updated to upstream version 1.4.54
 +
;libxslt: updated to upstream version 1.1.33
 +
;mdadm: updated to upstream version 4.1
 +
;monit: updated to upstream version 5.26.0
 +
;nano: updated to upstream version 4.3
 +
;nettle: updated to upstream version 3.5.1
 +
;nsd: updated to upstream version 4.2.1
 +
;pmacctd: updated to upstream version 1.7.3
 +
;pngquant: updated to upstream version 2.12.5
 +
;quagga: updated to upstream version 1.2.4
 +
;sqlite: updated to upstream version 3.29.0
 +
;tor: updated to upstream version 0.4.0.5
 +
;wireless-regdb: updated to upstream version 2019.06.03
 +
 
 +
;New Packages:
 +
;libmicrohttpd: GNU libmicrohttpd is a small C library that makes it easy to run an HTTP server as part of another application.
 +
;libcares: C library for asynchronous DNS requests
 +
 
 +
==Changes between 6.2.1 and 6.2.1-rc1==
 +
(released 10 Jun 2019)
 +
 
 +
;kernel: updated to upstream version 4.14.123
 +
;curl: updated to upstream version 7.65.1
 +
;axel: updated to upstream version 2.17.3
 +
;vnstat: updated to upstream version 2.2
 +
 
 +
==Changes between 6.2.1-rc1 and 6.2.0==
 +
(released 26 May 2019)
 +
 
 +
;kernel: updated to upstream version 4.14.121
 +
;initrd: add the correct new maintainer key in LEAF_sigkeys.gpg
 +
:fixed a bug in upgrade which caused the last package to be dropped
 +
:handle new dependencies in upgrade
 +
:Fix error parameter for file not found in gpg_functions
 +
;axel: updated to upstream version 2.17.1
 +
;bind: updated to upstream version 9.14.2
 +
;curl: updated to upstream version 7.65.0
 +
;dhcpcd: updated to upstream version 7.2.0
 +
;freetype: updated to upstream version 2.10.0
 +
:added libpng dependency
 +
;gdb: updated to upstream version 8.2.1
 +
;hostapd: updated to upstream version 2.8
 +
;igmpproxy: fix stop/restart
 +
;iw: updated to upstream version 5.0.1
 +
;ixgbe: update to 5.5.5
 +
;keepalived: updated to upstream version 2.0.15
 +
;libedit: updated to upstream version 20190324-3.1
 +
;libell: updated to upstream version 0.20
 +
;libpng: updated to upstream version 1.6.37
 +
;monit: updated to upstream version 5.25.3
 +
;nano: updated to upstream version 4.2
 +
;openssh: updated to upstream version 8.0p1
 +
;openssl: updated to pstream version 1.0.2r
 +
;perl: updated to upstream version 5.28.2
 +
;privoxy: updated to upstream version 3.0.28
 +
;python: updated tp upstream version 3.7.3
 +
;shorewall[6]: updated to upstream version 5.2.3.3
 +
;sqlite: updated to upstream version 3.28.0
 +
;stunnel: updated to upstream version 5.53
 +
;tor: updated to upstream version 0.3.5.8
 +
:fix torrc to start running as daemon by default
 +
;unbound: updated to upstream version 1.9.1
 +
;util-linux: updated to upstream version 2.33.2
 +
;valgrind: updated to upstream version 3.15.0
 +
;wget: updated to upstream version 1.20.3
 +
;wireless-regdb: updated to upstream version 2019.03.01
 +
;xl2tpd: updated to upstream version 1.3.14
 +
 
 +
;New Packages:
 +
<!--;libcap: Library implementing the user-space interfaces to the POSIX 1003.1e capabilities available in Linux kernels.
 +
:also adding a libcap-tools package-->
 +
;pngquant: a lossy png compressor
 +
;python-ply: PLY is yet another implementation of lex and yacc for Python
 +
 
 +
==Changes between 6.2.0 and 6.2.0-rc1==
 +
(released 3 Apr 2019)
 +
 
 +
;kernel: updated to upstream version 4.14.109
 +
;clamav: updated to upstream version 0.101.2
 +
;curl: updated to upstream version 7.64.1
 +
;dropbear: updated to upstream version 2019.78
 +
;keepalived: updated to upstream version 2.0.13
 +
;libreadline: updated to upstream version 8.0
 +
;libssh2: updated to upstream version 1.8.1
 +
;openvpn: updated to upstream version 2.4.7
 +
;pcre: updated to upstream version 8.43
 +
;shorewall[6]: updated to upstream version 5.2.3.2
 +
;strongswan: updated to upstream version 5.7.2
 +
;sqlite: updated to upstream version 3.27.2
 +
 
 +
==Changes between 6.2.0-rc1 and 6.2.0-beta1==
 +
(released 13 Mar 2019)
 +
 
 +
;general: disable spectre2 mitigation by default during boot in kernel command line, improves speed/CPU usage.
 +
:To change the default either delete the entry "spectre_v2=off" from the kernel command line or set "spectre_v2=on"
 +
;kernel: updated to upstream version 4.14.105
 +
;initrd: improve common_functions script to report success and/or failure
 +
;accel-ppp: update to trunk
 +
:load modules during startup
 +
;at: update to 3.1.23
 +
:disable libpam dependency
 +
;bind: updated to upstream version 9.12.3-P1
 +
;busybox: updated to upstream version 1.30.1
 +
;clamav: updated to upstream version 0.101.1
 +
;curl: updated to upstream version 7.64.0
 +
;dbus: updated to upstream version 1.12.12
 +
:fix system-socket creation
 +
;dmidecode: updated to upstream version 3.2
 +
;e1000e: updated to upstream version 3.4.2.1
 +
;heyu: updated to upstream version 2.11-rc3
 +
;iperf: updated to upstream version 2.0.13
 +
;ipset: add init script for saving/restoring/flushing rules
 +
:load modules during startup
 +
;iptables: load modules during startup
 +
;iw: updated to upstream version 5.0
 +
;jansson: updated to upstream version 2.12
 +
;keepalived: updated to upstream version 2.0.11
 +
;libell: updated to upstream version 0.17
 +
;libgpg-error: updated tp upstream version 1.35
 +
;libxml2: updated to upstream version 2.9.9
 +
;lighttpd: updated to upstream version 1.4.53
 +
;ntp: updated to upstream version 4.2.8p13
 +
;ser2net: updated to upstream version 3.5.1
 +
;shorewall[6]: updated to upstream version 5.2.3.1
 +
:shorewall[6]-lite: fix packaging shorewall[6]-lite
 +
;smartmontools: updated to upstream version 7.0
 +
;squid: updated to upstream version 4.6
 +
;stunnel: updated to upstream version 5.50
 +
;unbound: updated to upstream version 1.9.0
 +
;vnstat: updated to upstream version 2.1
 +
;wireless-regdb: updated to 2018.10.24
 +
;wpasupplicant: updated to upstream version 2.7
 +
 
 +
;New Packages:
 +
;python: Python interpreter
 +
;accelgui: web-based monitoring for accel-ppp
 +
;fail2ban: Fail2ban scans log files and bans IPs that show the malicious signs.
 +
;flup: collection of WSGI servers
 +
;freetype: a freely available software library to render fonts
 +
;webpy: web.py is a web framework for Python
 +
;rtl8812au: kernel driver for Realtek 802.11ac/abgn USB WLAN Network Controller
 +
 
 +
==Changes between 6.2.0-beta1 and 6.2.0-alpha2==
 +
(released 16 Jan 2019)
 +
 
 +
;kernel: updated to upstream version 4.14.93
 +
;accel-ppp: updated to latest trunk
 
;iptables: split package in iptables.lrp and libiptbl.lrp
 
;iptables: split package in iptables.lrp and libiptbl.lrp
 
:Most packages as shorewall, upnpd, xtables-addons just need the stuff from libiptbl.lrp, so let's save some space.
 
:Most packages as shorewall, upnpd, xtables-addons just need the stuff from libiptbl.lrp, so let's save some space.
 
;dosfstools: updated to upstream version 4.1
 
;dosfstools: updated to upstream version 4.1
 +
;igb: updated to upstream version 5.3.5.22
 +
;ixgbe: updated to upstream version 5.5.3
 
;libedit: updated to upstream version 20181209-3.1
 
;libedit: updated to upstream version 20181209-3.1
 
;libell: updated to upstream version 0.16
 
;libell: updated to upstream version 0.16
Line 19: Line 201:
 
;libgpg-error: updated to upstream version 1.33
 
;libgpg-error: updated to upstream version 1.33
 
;lmsensors: updated to upstream version 3.5.0
 
;lmsensors: updated to upstream version 3.5.0
 +
;lshw: updated to upstream version B.02.18
 +
;mpg123: updated to upstream version 1.25.10
 
;netatalk: updated to upstream version 3.1.12
 
;netatalk: updated to upstream version 3.1.12
 
;nsd: updated to upstream version 4.1.26
 
;nsd: updated to upstream version 4.1.26
 
;openldap: updated to upstream version 2.4.47
 
;openldap: updated to upstream version 2.4.47
 +
;rng-tools: updated to upstream version 6.6
 
;snort: updated to upstream version 2.9.12
 
;snort: updated to upstream version 2.9.12
 
;sqlite: updated to upstream version 3.26.0
 
;sqlite: updated to upstream version 3.26.0
 
;squid: updated to upstream version 4.4
 
;squid: updated to upstream version 4.4
 
;strace: updated to upstream version 4.26
 
;strace: updated to upstream version 4.26
 +
;tor: updated tp upstream version 3.4.10
 
;ulogd: updated to upstream version 2.0.7                                                                                                                     
 
;ulogd: updated to upstream version 2.0.7                                                                                                                     
 
:add support for sqlite3 with new package ulogd-sqlite3
 
:add support for sqlite3 with new package ulogd-sqlite3
;New Packages: libbsd - library providing useful functions commonly found on BSD systems
+
;util-linux: updated to upstream version 2.33.1
:libyaml - A YAML 1.1 parser and emitter written in C
+
 
 +
;New Packages:  
 +
;libbsd: library providing useful functions commonly found on BSD systems
 +
;libyaml: A YAML 1.1 parser and emitter written in C
  
 
==Changes between 6.2.0-alpha2 and 6.2.0-alpha1==
 
==Changes between 6.2.0-alpha2 and 6.2.0-alpha1==
Line 62: Line 251:
 
;xl2tpd: updated to ustream version 1.3.12
 
;xl2tpd: updated to ustream version 1.3.12
 
;yate: updated to upstream version 6.0.0.1
 
;yate: updated to upstream version 6.0.0.1
;New Packages: libedit - BSD line editing library
+
 
: libell - linux embedded library  
+
;New Packages:  
: file - file type identification utility
+
;libedit: BSD line editing library
:jansson - lightweight JSON library
+
;libell: linux embedded library  
 +
;file: file type identification utility
 +
;jansson: lightweight JSON library
  
 
==Changes between 6.1.5 and 6.2.0-alpha1==
 
==Changes between 6.1.5 and 6.2.0-alpha1==
Line 80: Line 271:
 
;stunnel: updated to upstrem version 5.49
 
;stunnel: updated to upstrem version 5.49
 
;tor: updated to upstream version 0.3.4.8
 
;tor: updated to upstream version 0.3.4.8
;New Package: picocom - Minimal dumb-terminal emulation program
+
 
 +
;New Package:  
 +
;picocom: Minimal dumb-terminal emulation program
 
----  
 
----  
 
{| summary="Navigation footer" width="100%"
 
{| summary="Navigation footer" width="100%"

Latest revision as of 14:44, 17 August 2019

Changelog
Bering-uClibc 6.x - Overview

Changes between 6.2.2-rc2 and 6.2.2-rc1

(unreleased)

kernel
updated to upstream version 4.14.138
geode-architecture: build the hardware random generator into the kernel and remove unnecessary modules
dhcpcd
updated to version 7.2.3 with important security fixes
libbsd
updated to upstream version 0.10.0
libell
updated to upstream version 0.21
libndp
updated to upstream version 1.7
mpg123
updated to upstream version 1.25.11
clamav
updated to upstream version 0.101.3
New Package
libarchive
Multi-format archive and compression library

Changes between 6.2.2-rc1 and 6.2.1

(released 7 Aug 2019)

general
provide images with signed packages only
fix WRAP image to support the max avail baud rate of 57600 instead of too fast chosen speed of 115200
kernel
updated to upstream version 4.14.135
(re)add bcm2835 watchdog module for Raspberry Pi 3
increase kmemleak initial buffer size
axel
updated to upstream version 2.17.5
bash
updated to upstream version 5.0 - patch level 007
busybox
updated to upstream version 1.31.0
curl
updated to upstream version 7.65.3
dbus
updated to upstream version 1.12.16
e2fsprogs
updated to upstream version 1.45.2
ethtool
updated to upstream version 5.2
expat
updated to upstream version 2.2.7
ipset
updated to upstream version 7.3
ixgbe
updated to 5.6.1
keepalived
updated to upstream version 2.0.17
libevent
updated to upstream version 2.1.11
libssh2
updated to upstream version 1.9.0
lighttpd
updated to upstream version 1.4.54
libxslt
updated to upstream version 1.1.33
mdadm
updated to upstream version 4.1
monit
updated to upstream version 5.26.0
nano
updated to upstream version 4.3
nettle
updated to upstream version 3.5.1
nsd
updated to upstream version 4.2.1
pmacctd
updated to upstream version 1.7.3
pngquant
updated to upstream version 2.12.5
quagga
updated to upstream version 1.2.4
sqlite
updated to upstream version 3.29.0
tor
updated to upstream version 0.4.0.5
wireless-regdb
updated to upstream version 2019.06.03
New Packages
libmicrohttpd
GNU libmicrohttpd is a small C library that makes it easy to run an HTTP server as part of another application.
libcares
C library for asynchronous DNS requests

Changes between 6.2.1 and 6.2.1-rc1

(released 10 Jun 2019)

kernel
updated to upstream version 4.14.123
curl
updated to upstream version 7.65.1
axel
updated to upstream version 2.17.3
vnstat
updated to upstream version 2.2

Changes between 6.2.1-rc1 and 6.2.0

(released 26 May 2019)

kernel
updated to upstream version 4.14.121
initrd
add the correct new maintainer key in LEAF_sigkeys.gpg
fixed a bug in upgrade which caused the last package to be dropped
handle new dependencies in upgrade
Fix error parameter for file not found in gpg_functions
axel
updated to upstream version 2.17.1
bind
updated to upstream version 9.14.2
curl
updated to upstream version 7.65.0
dhcpcd
updated to upstream version 7.2.0
freetype
updated to upstream version 2.10.0
added libpng dependency
gdb
updated to upstream version 8.2.1
hostapd
updated to upstream version 2.8
igmpproxy
fix stop/restart
iw
updated to upstream version 5.0.1
ixgbe
update to 5.5.5
keepalived
updated to upstream version 2.0.15
libedit
updated to upstream version 20190324-3.1
libell
updated to upstream version 0.20
libpng
updated to upstream version 1.6.37
monit
updated to upstream version 5.25.3
nano
updated to upstream version 4.2
openssh
updated to upstream version 8.0p1
openssl
updated to pstream version 1.0.2r
perl
updated to upstream version 5.28.2
privoxy
updated to upstream version 3.0.28
python
updated tp upstream version 3.7.3
shorewall[6]
updated to upstream version 5.2.3.3
sqlite
updated to upstream version 3.28.0
stunnel
updated to upstream version 5.53
tor
updated to upstream version 0.3.5.8
fix torrc to start running as daemon by default
unbound
updated to upstream version 1.9.1
util-linux
updated to upstream version 2.33.2
valgrind
updated to upstream version 3.15.0
wget
updated to upstream version 1.20.3
wireless-regdb
updated to upstream version 2019.03.01
xl2tpd
updated to upstream version 1.3.14
New Packages
pngquant
a lossy png compressor
python-ply
PLY is yet another implementation of lex and yacc for Python

Changes between 6.2.0 and 6.2.0-rc1

(released 3 Apr 2019)

kernel
updated to upstream version 4.14.109
clamav
updated to upstream version 0.101.2
curl
updated to upstream version 7.64.1
dropbear
updated to upstream version 2019.78
keepalived
updated to upstream version 2.0.13
libreadline
updated to upstream version 8.0
libssh2
updated to upstream version 1.8.1
openvpn
updated to upstream version 2.4.7
pcre
updated to upstream version 8.43
shorewall[6]
updated to upstream version 5.2.3.2
strongswan
updated to upstream version 5.7.2
sqlite
updated to upstream version 3.27.2

Changes between 6.2.0-rc1 and 6.2.0-beta1

(released 13 Mar 2019)

general
disable spectre2 mitigation by default during boot in kernel command line, improves speed/CPU usage.
To change the default either delete the entry "spectre_v2=off" from the kernel command line or set "spectre_v2=on"
kernel
updated to upstream version 4.14.105
initrd
improve common_functions script to report success and/or failure
accel-ppp
update to trunk
load modules during startup
at
update to 3.1.23
disable libpam dependency
bind
updated to upstream version 9.12.3-P1
busybox
updated to upstream version 1.30.1
clamav
updated to upstream version 0.101.1
curl
updated to upstream version 7.64.0
dbus
updated to upstream version 1.12.12
fix system-socket creation
dmidecode
updated to upstream version 3.2
e1000e
updated to upstream version 3.4.2.1
heyu
updated to upstream version 2.11-rc3
iperf
updated to upstream version 2.0.13
ipset
add init script for saving/restoring/flushing rules
load modules during startup
iptables
load modules during startup
iw
updated to upstream version 5.0
jansson
updated to upstream version 2.12
keepalived
updated to upstream version 2.0.11
libell
updated to upstream version 0.17
libgpg-error
updated tp upstream version 1.35
libxml2
updated to upstream version 2.9.9
lighttpd
updated to upstream version 1.4.53
ntp
updated to upstream version 4.2.8p13
ser2net
updated to upstream version 3.5.1
shorewall[6]
updated to upstream version 5.2.3.1
shorewall[6]-lite: fix packaging shorewall[6]-lite
smartmontools
updated to upstream version 7.0
squid
updated to upstream version 4.6
stunnel
updated to upstream version 5.50
unbound
updated to upstream version 1.9.0
vnstat
updated to upstream version 2.1
wireless-regdb
updated to 2018.10.24
wpasupplicant
updated to upstream version 2.7
New Packages
python
Python interpreter
accelgui
web-based monitoring for accel-ppp
fail2ban
Fail2ban scans log files and bans IPs that show the malicious signs.
flup
collection of WSGI servers
freetype
a freely available software library to render fonts
webpy
web.py is a web framework for Python
rtl8812au
kernel driver for Realtek 802.11ac/abgn USB WLAN Network Controller

Changes between 6.2.0-beta1 and 6.2.0-alpha2

(released 16 Jan 2019)

kernel
updated to upstream version 4.14.93
accel-ppp
updated to latest trunk
iptables
split package in iptables.lrp and libiptbl.lrp
Most packages as shorewall, upnpd, xtables-addons just need the stuff from libiptbl.lrp, so let's save some space.
dosfstools
updated to upstream version 4.1
igb
updated to upstream version 5.3.5.22
ixgbe
updated to upstream version 5.5.3
libedit
updated to upstream version 20181209-3.1
libell
updated to upstream version 0.16
libgcrypt
updated to upstream version 1.8.4
libgpg-error
updated to upstream version 1.33
lmsensors
updated to upstream version 3.5.0
lshw
updated to upstream version B.02.18
mpg123
updated to upstream version 1.25.10
netatalk
updated to upstream version 3.1.12
nsd
updated to upstream version 4.1.26
openldap
updated to upstream version 2.4.47
rng-tools
updated to upstream version 6.6
snort
updated to upstream version 2.9.12
sqlite
updated to upstream version 3.26.0
squid
updated to upstream version 4.4
strace
updated to upstream version 4.26
tor
updated tp upstream version 3.4.10
ulogd
updated to upstream version 2.0.7
add support for sqlite3 with new package ulogd-sqlite3
util-linux
updated to upstream version 2.33.1
New Packages
libbsd
library providing useful functions commonly found on BSD systems
libyaml
A YAML 1.1 parser and emitter written in C

Changes between 6.2.0-alpha2 and 6.2.0-alpha1

(released 15 Dec 2018)

general
uclibc-ng: updated to upstream version 1.0.31
gcc: updated to upstream version 6.5.0
binutils: updated to upstream version 2.31
kernel
updated to upstream version 4.14.85
bash
updated to upstream version 4.4p23
bind
updated to upstream version 9.12.3
dhcpd
updated to upstream version 4.4.1
ethtool
updated to upstream version 4.19
hostapd
updated to upstream version 2.7
ipset
updated to upstream version 7.1
krb5
updated to upstream version 1.16.2
libpcap
updated to upstream version 1.9.0
libtirpc
updated to upstream version 1.1.4
linux-atm
updated to upstream version 2.5.2
openssh
updated to upstream version 7.9p1
perl
updated to upstream version 5.28.1
screen
updated to upstream version 4.6.2
shorewall[6]
updated to upstream version 5.2.1.2
use perl module DIGEST:SHA instead of DIGEST:SHA1 (saves about 30kb RAM)
squid
updated to upstream version 4.3
strace
updated to upstream version 4.25
strongswan
updated to upstream version 5.7.1
tinyproxy
updated to upstream version 1.10.0
tor
updated to upstream version 0.3.4.9
unbound
updated to upstream version 1.8.3
vim
updated to upstream version 8.1
xl2tpd
updated to ustream version 1.3.12
yate
updated to upstream version 6.0.0.1
New Packages
libedit
BSD line editing library
libell
linux embedded library
file
file type identification utility
jansson
lightweight JSON library

Changes between 6.1.5 and 6.2.0-alpha1

(released 6 Oct 2018)

general
uClibc-ng: updated to upstream version 1.0.30
kernel
updated to 4.14.73
dbus
updated to upstream version 1.12.10
etc
remove outdated init.d/modutils script, long time replaced by various mechanisms improving modules loading
iproute
updated to upstream version 4.14.1
libgmp
updated to upstream version 6.1.2
nsd
updated to upstream version 4.1.24
openssh
updated to upstream version 7.8p1
stunnel
updated to upstrem version 5.49
tor
updated to upstream version 0.3.4.8
New Package
picocom
Minimal dumb-terminal emulation program

Up